Why Does Yahoo Hate Opera?

Via email: Yahoo! Mail is upgrading: What it means for you.

Dear Mike Cane,

Thank you for being a Yahoo! Mail user for the past 10 year(s). We look forward to bringing you an even faster, safer, easier-to-use Yahoo! Mail very soon.

Then:

You can upgrade now to the newest Yahoo! Mail if your browser is Internet Explorer 7, Firefox 3, Safari 4, or Chrome 5 or newer.

Given posts I have seen in the Opera Support forum, there is some sort on ongoing battle between Yahoo and Opera. Why, I have no effin idea. But people have posted that YMail does not work with Opera after the YMail upgrade.

Hey, Yahoo! This is supposed to be the world wide web. You should work with every browser. Fix it!

Advertisement

7 Comments

Filed under Personal

7 responses to “Why Does Yahoo Hate Opera?

  1. Simply change your browser identity in opera and it will work with new yahoo mail. I’ve marked my opera to report to yahoo as firefox. You can do that from Settings->Preferences->Content->Manage site preferences->network

  2. Ashok

    Just keep the old classic version of yahoo.It is much better than the new yahoo and old version loads faster than new version.
    Using opera 11.50

  3. hamza

    When will ymail continue to work with opera mini.

  4. glupaka

    i use yahoo’s mobile version – light and easy to use, little or no ads

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s